How to Download Photos and Videos from Your Gustavus Google Photos Storage

Problem


Students who are preparing for separation from Gustavus should check their Gustavus Google Photos storage to make sure no photos or videos that they would like to keep are stored there.

 

Environment


The article applies to Gustavus students who are transitioning away from their Gustavus Account and corresponding resources.

 

Resolution


1. Navigate to photos.google.com and log in using your Gustavus credentials
2. Any photos you see stored here should be downloaded to your local device and/or moved to a personal cloud storage of your choice

 

Downloading 1 photo at a time

1. Click on the photo or video you want to download
2. Click the 3 horizontal dots in the top right-hand corner
3. Click Download

 

Downloading multiple photos/videos

1. Hover over each photo/video you'd like to download and click the check mark icon in the upper left-hand corner
2. Once you've selected all of your photo/video files you'd like to download, click the vertical 3 dots in the upper right-hand corner and click download

 

Prepare, backup, and download all photos/videos

1. Click the settings icon in the upper right-hand corner
2. Scroll down to Export your Data and click the down arrow to expand the settings
3. Click the Backup link next to the heading Backup an archive of your data
4. Follow the prompts to use Google Takeout to create an archive file of your Google Photos data.  Be sure to follow the instructions fully and download your archive file to retain access to the files

 

Cause


Students will lose access to their Gustavus account approximately 90 days after graduation.  Review the full Student Account Retention Policy at gustavus.edu/technology/policy/studentaccount.

 

Contact Us

See support.google.com/ for additional support with any Google services. If you would like further assistance, please contact us at helpline@gustavus.edu or call us at 507-933-6111.