What to Do With a Phishing Email

Tags phishing

Problem


I may have received a phishing email and I am unsure what to do.

 

Environment


The article applies to members of Gustavus who have received a phishing attempt.

 

Resolution


  1. Don't click on the message
  2. Don't reply to the message.
  3. Click the box to the left of the message
  4. Click Report as Spam (exclamation point in the top menu)

You can also forward any suspected phishing attempts to the Technology Helpline at helpline@gustavus.edu.  We will be happy to evaluate any suspect messages.

If you believe you may have already sent sensitive information, or fallen victim to a phishing attempt, please change your password and contact the Technology Helpline immediately at 507-933-6111 or helpline@gustavus.edu.

 

Cause


In the field of computer security, "phishing" is the criminally fraudulent process of attempting to acquire sensitive information such as usernames, passwords and credit card details by masquerading as a trustworthy entity in an electronic communication, such as e-mail.

Never send any sensitive information (passwords, Social Security Numbers, date of birth, credit card info) in an e-mail, even if you know who you are sending it to. GTS will never ask you for your password, ever. 

 

Contact Us

If you would like further assistance, please contact us at helpline@gustavus.edu or call us at 507-933-6111.