Problem
How can a proxy of Self Service change or reset their password?
Environment
The article applies to parents/guardians given proxy access to a student's account.
Resolution
A proxy can request their password be reset by sending an email to proxyaccess@gustavus.edu with any relevant information (name, relationship, etc).
AIS will create and email a temporary password to the proxy using the email that is on file for proxy communications. The proxy will be required to change their password afterward.
Cause
Proxies are not able to change or reset their password by themself.
Contact Us
If you would like further assistance, please contact us at helpline@gustavus.edu or call us at 507-933-6111.