Problem
After printing documents, they are not coming out of the printer.
Environment
The article applies to Gustavus students trying to print.
Resolution
- Walk up to any student printer and tap your Gustavus ID card.
- Select the jobs pending release tab.
- Select the jobs you would like to release and click release.
Note: If a print job is not released within 24 hours of being added to the print queue, it will be automatically deleted from the print queue and no charging will occur.
Cause
Print job needs to be released in order to print.
Contact Us
If you would further assistance, please contact us at helpline@gustavus.edu or call us at 507-933-6111.